#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\[monitor:///var/log/(?:messages|secure)\](?:(?:\R.*){2})index=)power"
Local $sString = "[monitor:///var/log/messages]" & @CRLF & _
"sourcetype=linux" & @CRLF & _
"index=power" & @CRLF & _
"" & @CRLF & _
"[monitor:///var/log/secure]" & @CRLF & _
"sourcetype=linux" & @CRLF & _
"index=power"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")