const regex = new RegExp('(\\[monitor:///var/log/(?:messages|secure)\\](?:(?:\\R.*){2})index=)power', 'gm')
const str = `[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}