package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[monitor:///var/log/(?:messages|secure)\](?:(?:\R.*){2})index=)power`)
var str = `[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}