re = /(\[monitor:\/\/\/var\/log\/(?:messages|secure)\](?:(?:\R.*){2})index=)power/m
str = '[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end