$re = '`(\[monitor:///var/log/(?:messages|secure)\](?:(?:\R.*){2})index=)power`m';
$str = '[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);