package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d\d\.\d{3}\.\d{3}-\d{4}-\d\d)`)
var str = `123.123.123-99
12.123.123-1234-99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}