re = /(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d\d\.\d{3}\.\d{3}-\d{4}-\d\d)/m
str = '123.123.123-99
12.123.123-1234-99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end