import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3}\\.\\d{3}\\.\\d{3}-\\d{2})|(\\d\\d\\.\\d{3}\\.\\d{3}-\\d{4}-\\d\\d)";
final String string = "123.123.123-99\n\n"
+ "12.123.123-1234-99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}