$re = '/(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d\d\.\d{3}\.\d{3}-\d{4}-\d\d)/m';
$str = '123.123.123-99
12.123.123-1234-99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);