const regex = /(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d\d\.\d{3}\.\d{3}-\d{4}-\d\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3}\\.\\d{3}\\.\\d{3}-\\d{2})|(\\d\\d\\.\\d{3}\\.\\d{3}-\\d{4}-\\d\\d)', 'gm')
const str = `123.123.123-99
12.123.123-1234-99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}