import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\/(?:(?:test|something)(?:\\/|$)|$))";
final String string = "/\n"
+ "/test\n"
+ "/test/\n"
+ "/test/tjghdf\n"
+ "/something\n"
+ "/something/\n"
+ "/something/sdfdsf\n\n"
+ "/config\n"
+ "/config/\n"
+ "/config/sdfdsf\n"
+ "/notallowed\n"
+ "/notallowed/\n"
+ "/notallowed/dsfsf\n\n"
+ "/test%2F..%2Fconfig # This one does not return 404 even though doesn't match the regex\n\n"
+ "/test/..%2Fconfig # This matches and lets you get /config";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}