const regex = /(^\/(?:(?:test|something)(?:\/|$)|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\\/(?:(?:test|something)(?:\\\/|$)|$))', 'gm')
const str = `/
/test
/test/
/test/tjghdf
/something
/something/
/something/sdfdsf
/config
/config/
/config/sdfdsf
/notallowed
/notallowed/
/notallowed/dsfsf
/test%2F..%2Fconfig # This one does not return 404 even though doesn't match the regex
/test/..%2Fconfig # This matches and lets you get /config`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}