re = /(^\/(?:(?:test|something)(?:\/|$)|$))/m
str = '/
/test
/test/
/test/tjghdf
/something
/something/
/something/sdfdsf
/config
/config/
/config/sdfdsf
/notallowed
/notallowed/
/notallowed/dsfsf
/test%2F..%2Fconfig # This one does not return 404 even though doesn\'t match the regex
/test/..%2Fconfig # This matches and lets you get /config'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end