import Foundation
let pattern = #"(^\/(?:(?:test|something)(?:\/|$)|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/
/test
/test/
/test/tjghdf
/something
/something/
/something/sdfdsf
/config
/config/
/config/sdfdsf
/notallowed
/notallowed/
/notallowed/dsfsf
/test%2F..%2Fconfig # This one does not return 404 even though doesn't match the regex
/test/..%2Fconfig # This matches and lets you get /config
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)