$re = '/(^\/(?:(?:test|something)(?:\/|$)|$))/m';
$str = '/
/test
/test/
/test/tjghdf
/something
/something/
/something/sdfdsf
/config
/config/
/config/sdfdsf
/notallowed
/notallowed/
/notallowed/dsfsf
/test%2F..%2Fconfig # This one does not return 404 even though doesn\'t match the regex
/test/..%2Fconfig # This matches and lets you get /config';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);