using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([PpDdQq]\w*o)(?:\s+(\w*me))?\b(.*)";
string input = @"Yo quiero irme de viaje.
Yo puedo caminar en la nieve.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}