package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([PpDdQq]\w*o)(?:\s+(\w*me))?\b(.*)`)
var str = `Yo quiero irme de viaje.
Yo puedo caminar en la nieve.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}