// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([PpDdQq]\w*o)(?:\s+(\w*me))?\b(.*)").unwrap();
let string = "Yo quiero irme de viaje.
Yo puedo caminar en la nieve.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}