$re = '/\b([PpDdQq]\w*o)(?:\s+(\w*me))?\b(.*)/m';
$str = 'Yo quiero irme de viaje.
Yo puedo caminar en la nieve.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);