re = /\b([PpDdQq]\w*o)(?:\s+(\w*me))?\b(.*)/m
str = 'Yo quiero irme de viaje.
Yo puedo caminar en la nieve.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end