$re = '/^[\w\d]+([+.][\w\d]+)*@$/m';
$str = 'john.seed@
bennormw@
john..seed@
john.+++.+.seed@
john..seed@
.john.seed@
+john.seed@
john.seed.++.+.@
john.seed@
a.@
d.d@
d+d@
d+.d@
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);