re = /^[\w\d]+([+.][\w\d]+)*@$/m
str = 'john.seed@
bennormw@
john..seed@
john.+++.+.seed@
john..seed@
.john.seed@
+john.seed@
john.seed.++.+.@
john.seed@
a.@
d.d@
d+d@
d+.d@
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end