using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span.*?>(.*?)<\/span>";
string input = @"<span aria-hidden=""true"" class=""line-numbers-rows""><span></span><span></span><span></span></span>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}