// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<span.*?>(.*?)<\/span>").unwrap();
let string = "<span aria-hidden=\"true\" class=\"line-numbers-rows\"><span></span><span></span><span></span></span>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}