re = /<span.*?>(.*?)<\/span>/
str = '<span aria-hidden="true" class="line-numbers-rows"><span></span><span></span><span></span></span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end