package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span.*?>(.*?)<\/span>`)
var str = `<span aria-hidden="true" class="line-numbers-rows"><span></span><span></span><span></span></span>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}