$re = '/<span.*?>(.*?)<\/span>/';
$str = '<span aria-hidden="true" class="line-numbers-rows"><span></span><span></span><span></span></span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);