#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\d[\d.\s,]*)(?:\s(?:euro|€|Euro))|\d)$"
Local $sString = "9847, 48 euro" & @CRLF & _
"1929, 78 Euro" & @CRLF & _
"1 Euro" & @CRLF & _
"70 000 Euro" & @CRLF & _
"70 000 €" & @CRLF & _
"12345 €" & @CRLF & _
"1234 €" & @CRLF & _
"123 €" & @CRLF & _
"12345,99 €" & @CRLF & _
"1234.99 €" & @CRLF & _
"123 €" & @CRLF & _
"99 €" & @CRLF & _
"99.99 €" & @CRLF & _
"99,99 Euro" & @CRLF & _
"100" & @CRLF & _
"12345" & @CRLF & _
"1234" & @CRLF & _
"123" & @CRLF & _
"12345 " & @CRLF & _
"1234 " & @CRLF & _
"123 " & @CRLF & _
"1.0 " & @CRLF & _
"10.00" & @CRLF & _
"100.00" & @CRLF & _
"1,000.00" & @CRLF & _
"10,000.00" & @CRLF & _
"100,000.00" & @CRLF & _
"1,000,000.00" & @CRLF & _
"1.0 Euro" & @CRLF & _
"10.00 Euro" & @CRLF & _
"100.00 €" & @CRLF & _
"1,000.00 €" & @CRLF & _
"10,000.00" & @CRLF & _
"100,000.00 euro" & @CRLF & _
"1,000,000.00 Euro" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")