const regex = new RegExp('^((\\d[\\d.\\s,]*)(?:\\s(?:euro|€|Euro))|\\d)$', 'gm')
const str = `9847, 48 euro
1929, 78 Euro
1 Euro
70 000 Euro
70 000 €
12345 €
1234 €
123 €
12345,99 €
1234.99 €
123 €
99 €
99.99 €
99,99 Euro
100
12345
1234
123
12345
1234
123
1.0
10.00
100.00
1,000.00
10,000.00
100,000.00
1,000,000.00
1.0 Euro
10.00 Euro
100.00 €
1,000.00 €
10,000.00
100,000.00 euro
1,000,000.00 Euro
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}