# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\d[\d.\s,]*)(?:\s(?:euro|€|Euro))|\d)$"
test_str = ("9847, 48 euro\n"
"1929, 78 Euro\n"
"1 Euro\n"
"70 000 Euro\n"
"70 000 €\n"
"12345 €\n"
"1234 €\n"
"123 €\n"
"12345,99 €\n"
"1234.99 €\n"
"123 €\n"
"99 €\n"
"99.99 €\n"
"99,99 Euro\n"
"100\n"
"12345\n"
"1234\n"
"123\n"
"12345 \n"
"1234 \n"
"123 \n"
"1.0 \n"
"10.00\n"
"100.00\n"
"1,000.00\n"
"10,000.00\n"
"100,000.00\n"
"1,000,000.00\n"
"1.0 Euro\n"
"10.00 Euro\n"
"100.00 €\n"
"1,000.00 €\n"
"10,000.00\n"
"100,000.00 euro\n"
"1,000,000.00 Euro\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.