import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\d[\\d.\\s,]*)(?:\\s(?:euro|€|Euro))|\\d)$";
final String string = "9847, 48 euro\n"
+ "1929, 78 Euro\n"
+ "1 Euro\n"
+ "70 000 Euro\n"
+ "70 000 €\n"
+ "12345 €\n"
+ "1234 €\n"
+ "123 €\n"
+ "12345,99 €\n"
+ "1234.99 €\n"
+ "123 €\n"
+ "99 €\n"
+ "99.99 €\n"
+ "99,99 Euro\n"
+ "100\n"
+ "12345\n"
+ "1234\n"
+ "123\n"
+ "12345 \n"
+ "1234 \n"
+ "123 \n"
+ "1.0 \n"
+ "10.00\n"
+ "100.00\n"
+ "1,000.00\n"
+ "10,000.00\n"
+ "100,000.00\n"
+ "1,000,000.00\n"
+ "1.0 Euro\n"
+ "10.00 Euro\n"
+ "100.00 €\n"
+ "1,000.00 €\n"
+ "10,000.00\n"
+ "100,000.00 euro\n"
+ "1,000,000.00 Euro\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}