package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\d[\d.\s,]*)(?:\s(?:euro|€|Euro))|\d)$`)
var str = `9847, 48 euro
1929, 78 Euro
1 Euro
70 000 Euro
70 000 €
12345 €
1234 €
123 €
12345,99 €
1234.99 €
123 €
99 €
99.99 €
99,99 Euro
100
12345
1234
123
12345
1234
123
1.0
10.00
100.00
1,000.00
10,000.00
100,000.00
1,000,000.00
1.0 Euro
10.00 Euro
100.00 €
1,000.00 €
10,000.00
100,000.00 euro
1,000,000.00 Euro
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}