#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)calc\([^\)]*\)"
Local $sString = ".test-calc {" & @CRLF & _
" left:calc(50% - (100px * 2));" & @CRLF & _
" width: calc( 25% + 10px);" & @CRLF & _
" right: calc(((100% - 1200px) / 2) + 16px);" & @CRLF & _
" height:calc(50% + 4px)" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")