const regex = new RegExp('calc\\([^\\)]*\\)', 'gm')
const str = `.test-calc {
left:calc(50% - (100px * 2));
width: calc( 25% + 10px);
right: calc(((100% - 1200px) / 2) + 16px);
height:calc(50% + 4px)
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}