package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)calc\([^\)]*\)`)
var str = `.test-calc {
left:calc(50% - (100px * 2));
width: calc( 25% + 10px);
right: calc(((100% - 1200px) / 2) + 16px);
height:calc(50% + 4px)
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}