re = /calc\([^\)]*\)/m
str = '.test-calc {
left:calc(50% - (100px * 2));
width: calc( 25% + 10px);
right: calc(((100% - 1200px) / 2) + 16px);
height:calc(50% + 4px)
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end