// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)calc\([^\)]*\)").unwrap();
let string = ".test-calc {
left:calc(50% - (100px * 2));
width: calc( 25% + 10px);
right: calc(((100% - 1200px) / 2) + 16px);
height:calc(50% + 4px)
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}