#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s,]([^,]*[^\s,])?$"
Local $sString = "abc" & @CRLF & _
",ggd," & @CRLF & _
"a" & @CRLF & _
"dbb," & @CRLF & _
"abc xyz gddd" & @CRLF & _
" adadadad dfgdfgdgddgdggdd," & @CRLF & _
"" & @CRLF & _
" ddd bbb" & @CRLF & _
"ggg "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")