package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s,]([^,]*[^\s,])?$`)
var str = `abc
,ggd,
a
dbb,
abc xyz gddd
adadadad dfgdfgdgddgdggdd,
ddd bbb
ggg `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}