$re = '/^[^\s,]([^,]*[^\s,])?$/m';
$str = 'abc
,ggd,
a
dbb,
abc xyz gddd
adadadad dfgdfgdgddgdggdd,
ddd bbb
ggg ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);