using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s,]([^,]*[^\s,])?$";
string input = @"abc
,ggd,
a
dbb,
abc xyz gddd
adadadad dfgdfgdgddgdggdd,
ddd bbb
ggg ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}