re = /^[^\s,]([^,]*[^\s,])?$/m
str = 'abc
,ggd,
a
dbb,
abc xyz gddd
adadadad dfgdfgdgddgdggdd,
ddd bbb
ggg '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end