# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^(Ab&c\%1))(\d{2,})/1999/gm;t' <<< "Ab&c%1250Ab&c%1
Ab&c%1250
Ab&c%1350Ab&c%1
Ab&c%1350"