import Foundation
let pattern = #"(?!^(Ab&c\%1))(\d{2,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ab&c%1250Ab&c%1
Ab&c%1250
Ab&c%1350Ab&c%1
Ab&c%1350
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1999"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)