using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^(Ab&c\%1))(\d{2,})";
string substitution = @"1999";
string input = @"Ab&c%1250Ab&c%1
Ab&c%1250
Ab&c%1350Ab&c%1
Ab&c%1350";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}