#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^(Ab&c\%1))(\d{2,})"
Local $sString = "Ab&c%1250Ab&c%1" & @CRLF & _
"Ab&c%1250" & @CRLF & _
"Ab&c%1350Ab&c%1" & @CRLF & _
"Ab&c%1350"
Local $sSubst = "1999"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)