$re = '/(?!^(Ab&c\%1))(\d{2,})/m';
$str = 'Ab&c%1250Ab&c%1
Ab&c%1250
Ab&c%1350Ab&c%1
Ab&c%1350';
$subst = "1999";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;