use strict;
my $str = '55555Paul
555556Sarah
';
my $regex = qr/[a-zA-Z]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";