import re
regex = re.compile(r"[a-zA-Z]", flags=re.MULTILINE)
test_str = ("55555Paul\n"
"555556Sarah\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)