#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.edu(?:\.\w{2,3})?$"
Local $sString = ".xx" & @CRLF & _
"school.edu.au" & @CRLF & _
"college.edu.uk" & @CRLF & _
".edu" & @CRLF & _
"school.edu" & @CRLF & _
"student.college.edu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")